use strict;
my $str = 'שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול';
my $regex = qr/(?'first'.+\s)(\k'first')/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";