using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'first'.+\s)(\k'first')";
string substitution = @"\1";
string input = @"שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}