# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?'first'.+\s)(\k'first')/\1/gm;t' <<< "שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול"