const regex = /(?'first'.+\s)(\k'first')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'first\'.+\\s)(\\k\'first\')', 'gm')
const str = `שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);