re = /(A)\s*&\s*(B)\s*/m
str = 'Leadership Class A & B
Rock Class A & B
Theatre Class A & B
Leadership Class A & B
A & Leadership Class A & B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end