package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(A)\s*&\s*(B)\s*`)
var str = `Leadership Class A & B
Rock Class A & B
Theatre Class A & B
Leadership Class A & B
A & Leadership Class A & B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}