import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(A)\\s*&\\s*(B)\\s*";
final String string = "Leadership Class A & B\n"
+ "Rock Class A & B \n"
+ "Theatre Class A & B\n"
+ "Leadership Class A & B\n"
+ "A & Leadership Class A & B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}