$re = '/(A)\s*&\s*(B)\s*/m';
$str = 'Leadership Class A & B
Rock Class A & B
Theatre Class A & B
Leadership Class A & B
A & Leadership Class A & B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);