using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(A)\s*&\s*(B)\s*";
string input = @"Leadership Class A & B
Rock Class A & B
Theatre Class A & B
Leadership Class A & B
A & Leadership Class A & B";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}