// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ms)(?i)Rem\s+((\[(s|none|success|inconclusive|failed|error)\]\s+)|)(\".*\"|\'.*\')"#).unwrap();
let string = "REM '\"基于ECU-TEST结合CANape实现标定测试'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}