package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(?i)Rem\s+((\[(s|none|success|inconclusive|failed|error)\]\s+)|)(\".*\"|\'.*\')`)
var str = `REM '"基于ECU-TEST结合CANape实现标定测试'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}