re = /(?i)Rem\s+((\[(s|none|success|inconclusive|failed|error)\]\s+)|)(\".*\"|\'.*\')/m
str = 'REM \'"基于ECU-TEST结合CANape实现标定测试\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end