const regex = new RegExp('(?i)Rem\\s+((\\[(s|none|success|inconclusive|failed|error)\\]\\s+)|)(\\".*\\"|\\\\'.*\\\\')', 'gms')
const str = `REM '"基于ECU-TEST结合CANape实现标定测试'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}