using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)Rem\s+((\[(s|none|success|inconclusive|failed|error)\]\s+)|)(\"".*\""|\'.*\')";
string input = @"REM '""基于ECU-TEST结合CANape实现标定测试'";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}