re = /(\w+?) +f\((.+?)\)= *(.+)/m
str = 'local r f(table.foreach)= print'
subst = '\\1 = \\2(\\1, \\3)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result