package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+?) +f\((.+?)\)= *(.+)`)
var str = `local r f(table.foreach)= print`
var substitution = "\1 = \2(\1, \3)"
fmt.Println(re.ReplaceAllString(str, substitution))
}