const regex = new RegExp('(\\w+?) +f\\((.+?)\\)= *(.+)', 'gm')
const str = `local r f(table.foreach)= print`;
const subst = `\1 = \2(\1, \3)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);