$re = '/(\w+?) +f\((.+?)\)= *(.+)/m';
$str = 'local r f(table.foreach)= print';
$subst = "\1 = \2(\1, \3)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;