use strict;
my $str = 'local r f(table.foreach)= print';
my $regex = qr/(\w+?) +f\((.+?)\)= *(.+)/mp;
my $subst = '\\1 = \\2(\\1, \\3)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";