import Foundation
let pattern = #"(?:.[.]\s+(.*?)(?=\n|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. 1x1s with David and Greg; research team meeting; non-IRS work; CTC-UP UT report; future UT planning
2. Sprint planning; CTC-UP UT Rd 2 planning meeting; 1x1 with Edward; weekly design sync; research touch-base with interns
3. no blockers
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)