$re = '/(?:.[.]\s+(.*?)(?=\n|$))/m';
$str = '1. 1x1s with David and Greg; research team meeting; non-IRS work; CTC-UP UT report; future UT planning
2. Sprint planning; CTC-UP UT Rd 2 planning meeting; 1x1 with Edward; weekly design sync; research touch-base with interns
3. no blockers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);