import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.[.]\\s+(.*?)(?=\\n|$))";
final String string = "1. 1x1s with David and Greg; research team meeting; non-IRS work; CTC-UP UT report; future UT planning\n"
+ "2. Sprint planning; CTC-UP UT Rd 2 planning meeting; 1x1 with Edward; weekly design sync; research touch-base with interns\n"
+ "3. no blockers";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}