use strict;
my $str = '1. 1x1s with David and Greg; research team meeting; non-IRS work; CTC-UP UT report; future UT planning
2. Sprint planning; CTC-UP UT Rd 2 planning meeting; 1x1 with Edward; weekly design sync; research touch-base with interns
3. no blockers';
my $regex = qr/(?:.[.]\s+(.*?)(?=\n|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}