using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.[.]\s+(.*?)(?=\n|$))";
string input = @"1. 1x1s with David and Greg; research team meeting; non-IRS work; CTC-UP UT report; future UT planning
2. Sprint planning; CTC-UP UT Rd 2 planning meeting; 1x1 with Edward; weekly design sync; research touch-base with interns
3. no blockers";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}