import Foundation
let pattern = #"^(?!enum).*class\b\s\b[A-Za-z_][A-Za-z_0-9]*\b\s*($)?(|:\s*($)?(public|private|protected))\s*(.*?)\s*(({$)|(}$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
using UnityEngine;
namespace test{
public class PlayerController : MonoBehaviour { }
public class DoorControl : MonoBehaviour
{
private class DoorControl : MonoBehaviour
{
public class DoorControl
{
public static class DoorControl
{
public class DoorControl {
public class DoorControl : MonoBehaviour, test
{
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)