$re = '/^(?!enum).*class\b\s\b[A-Za-z_][A-Za-z_0-9]*\b\s*($)?(|:\s*($)?(public|private|protected))\s*(.*?)\s*(({$)|(}$))/m';
$str = 'using UnityEngine;
namespace test{
public class PlayerController : MonoBehaviour { }
public class DoorControl : MonoBehaviour
{
private class DoorControl : MonoBehaviour
{
public class DoorControl
{
public static class DoorControl
{
public class DoorControl {
public class DoorControl : MonoBehaviour, test
{
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);