use strict;
my $str = 'using UnityEngine;
namespace test{
public class PlayerController : MonoBehaviour { }
public class DoorControl : MonoBehaviour
{
private class DoorControl : MonoBehaviour
{
public class DoorControl
{
public static class DoorControl
{
public class DoorControl {
public class DoorControl : MonoBehaviour, test
{
';
my $regex = qr/^(?!enum).*class\b\s\b[A-Za-z_][A-Za-z_0-9]*\b\s*($)?(|:\s*($)?(public|private|protected))\s*(.*?)\s*(({$)|(}$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}