using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!enum).*class\b\s\b[A-Za-z_][A-Za-z_0-9]*\b\s*($)?(|:\s*($)?(public|private|protected))\s*(.*?)\s*(({$)|(}$))";
string input = @"using UnityEngine;
namespace test{
public class PlayerController : MonoBehaviour { }
public class DoorControl : MonoBehaviour
{
private class DoorControl : MonoBehaviour
{
public class DoorControl
{
public static class DoorControl
{
public class DoorControl {
public class DoorControl : MonoBehaviour, test
{
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}