import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!enum).*class\\b\\s\\b[A-Za-z_][A-Za-z_0-9]*\\b\\s*($)?(|:\\s*($)?(public|private|protected))\\s*(.*?)\\s*((\\{$)|(\\}$))";
final String string = "using UnityEngine;\n"
+ "namespace test{\n"
+ " public class PlayerController : MonoBehaviour { }\n"
+ " public class DoorControl : MonoBehaviour\n"
+ " {\n"
+ " private class DoorControl : MonoBehaviour\n"
+ " {\n"
+ " public class DoorControl\n"
+ " {\n"
+ " public static class DoorControl\n"
+ " {\n"
+ " public class DoorControl {\n"
+ " public class DoorControl : MonoBehaviour, test\n"
+ " {\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}