re = /(^.*)(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%n@%m%)(?:{\$\w*%})\s(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%~)(?:%{\$\w*%})(\s*\$\(\w*\))/
str = '╭─%{$terminfo[bold]$fg[green]%}%n@%m%{$reset_color%} %{$terminfo[bold]$fg[blue]%}%~%{$reset_color%} $(git_prompt_info)%{$reset_color%}
╰─%B╼%b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end