const regex = /(^.*)(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%n@%m%)(?:{\$\w*%})\s(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%~)(?:%{\$\w*%})(\s*\$\(\w*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*)(?:%{\\$\\w*\\[\\w*\\]\\$\\w*\\[\\w*\\]%})(%n@%m%)(?:{\\$\\w*%})\\s(?:%{\\$\\w*\\[\\w*\\]\\$\\w*\\[\\w*\\]%})(%~)(?:%{\\$\\w*%})(\\s*\\$\\(\\w*\\))', 'g')
const str = `╭─%{\$terminfo[bold]\$fg[green]%}%n@%m%{\$reset_color%} %{\$terminfo[bold]\$fg[blue]%}%~%{\$reset_color%} \$(git_prompt_info)%{\$reset_color%}
╰─%B╼%b
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}