package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^.*)(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%n@%m%)(?:{\$\w*%})\s(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%~)(?:%{\$\w*%})(\s*\$\(\w*\))`)
var str = `╭─%{$terminfo[bold]$fg[green]%}%n@%m%{$reset_color%} %{$terminfo[bold]$fg[blue]%}%~%{$reset_color%} $(git_prompt_info)%{$reset_color%}
╰─%B╼%b
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}