import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*)(?:%\\{\\$\\w*\\[\\w*\\]\\$\\w*\\[\\w*\\]%\\})(%n@%m%)(?:\\{\\$\\w*%\\})\\s(?:%\\{\\$\\w*\\[\\w*\\]\\$\\w*\\[\\w*\\]%\\})(%~)(?:%\\{\\$\\w*%\\})(\\s*\\$\\(\\w*\\))";
final String string = "╭─%{$terminfo[bold]$fg[green]%}%n@%m%{$reset_color%} %{$terminfo[bold]$fg[blue]%}%~%{$reset_color%} $(git_prompt_info)%{$reset_color%}\n"
+ "╰─%B╼%b\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}