$re = '/(^.*)(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%n@%m%)(?:{\$\w*%})\s(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%~)(?:%{\$\w*%})(\s*\$\(\w*\))/';
$str = '╭─%{$terminfo[bold]$fg[green]%}%n@%m%{$reset_color%} %{$terminfo[bold]$fg[blue]%}%~%{$reset_color%} $(git_prompt_info)%{$reset_color%}
╰─%B╼%b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);