$re = '/(?<=gene=).+?(?=\])/m';
$str = '>lcl|NC_001802.1_cds_NP_057851.1_3 [gene=vif] [locus_tag=HIV1gp3] [db_xref=GeneID:155459] [protein=Vif] [protein_id=NP_057851.1] [location=4587..5165] [gbkey=CDS]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);