using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=gene=).+?(?=\])";
string input = @">lcl|NC_001802.1_cds_NP_057851.1_3 [gene=vif] [locus_tag=HIV1gp3] [db_xref=GeneID:155459] [protein=Vif] [protein_id=NP_057851.1] [location=4587..5165] [gbkey=CDS]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}