use strict;
my $str = '>lcl|NC_001802.1_cds_NP_057851.1_3 [gene=vif] [locus_tag=HIV1gp3] [db_xref=GeneID:155459] [protein=Vif] [protein_id=NP_057851.1] [location=4587..5165] [gbkey=CDS]
';
my $regex = qr/(?<=gene=).+?(?=\])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}