#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=gene=).+?(?=\])"
Local $sString = ">lcl|NC_001802.1_cds_NP_057851.1_3 [gene=vif] [locus_tag=HIV1gp3] [db_xref=GeneID:155459] [protein=Vif] [protein_id=NP_057851.1] [location=4587..5165] [gbkey=CDS]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")