import Foundation
let pattern = #"<td.+>(?:<.*>)*?(.+?)(?:<.*>)*?<\/td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><bold>1/29/2017</bold></td>
<tbody>
<tr>
<td nowrap=\"nowrap\" style=\"width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>5070</strong></td>
<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\">1/29/2017</td>
<td nowrap=\"nowrap\" style=\"width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>11:00 AM</strong></td>
<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>88-14-Glendale SC#5</strong></td>
<td nowrap=\"nowrap\" style=\"width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS</strong></td>
<td nowrap=\"nowrap\" style=\"width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS-88-Grakasian</strong></td>
<td nowrap=\"nowrap\" style=\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS-13-Way</strong></td>
<td nowrap=\"nowrap\" style=\"width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>88</strong></td>
<td nowrap=\"nowrap\" style=\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>Region 88</strong></td>
<td nowrap=\"nowrap\" style=\"width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>Region 88</strong></td>
<td nowrap=\"nowrap\" style=\"width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>Region 88</strong></td>
</tr>
<tr>
<td nowrap=\"nowrap\" style=\"width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>6022</strong></td>
<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>1/29/2017</strong></td>
<td nowrap=\"nowrap\" style=\"width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>12:30 PM</strong></td>
<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>88-14-Glendale SC#5</strong></td>
<td nowrap=\"nowrap\" style=\"width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14GA</strong></td>
<td nowrap=\"nowrap\" style=\"width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14GA-88A-Boehm</strong></td>
<td nowrap=\"nowrap\" style=\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14GA-13B-Baer</strong></td>
<td nowrap=\"nowrap\" style=\"width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>88</strong></td>
<td nowrap=\"nowrap\" style=\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>Region 88</strong></td>
<td nowrap=\"nowrap\" style=\"width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS-88-Grakasian(HELP)</strong></td>
<td nowrap=\"nowrap\" style=\"width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS-13-Way</strong></td>
</tr>
</tbody>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)