using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<td.+>(?:<.*>)*?(.+?)(?:<.*>)*?<\/td>";
string input = @"<td nowrap=\""nowrap\"" style=\""width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><bold>1/29/2017</bold></td>
<tbody>
<tr>
<td nowrap=\""nowrap\"" style=\""width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>5070</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"">1/29/2017</td>
<td nowrap=\""nowrap\"" style=\""width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>11:00 AM</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>88-14-Glendale SC#5</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>U14BS</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>U14BS-88-Grakasian</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>U14BS-13-Way</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>88</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>Region 88</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>Region 88</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>Region 88</strong></td>
</tr>
<tr>
<td nowrap=\""nowrap\"" style=\""width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>6022</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>1/29/2017</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>12:30 PM</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>88-14-Glendale SC#5</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>U14GA</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>U14GA-88A-Boehm</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>U14GA-13B-Baer</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>88</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>Region 88</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>U14BS-88-Grakasian(HELP)</strong></td>
<td nowrap=\""nowrap\"" style=\""width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\""><strong>U14BS-13-Way</strong></td>
</tr>
</tbody>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}