import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td.+>(?:<.*>)*?(.+?)(?:<.*>)*?<\\/td>";
final String string = "<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><bold>1/29/2017</bold></td>\n\n\n\n\n"
+ "<tbody>\n"
+ "<tr>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>5070</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\">1/29/2017</td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>11:00 AM</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>88-14-Glendale SC#5</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS-88-Grakasian</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS-13-Way</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>88</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>Region 88</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>Region 88</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>Region 88</strong></td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>6022</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>1/29/2017</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>12:30 PM</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>88-14-Glendale SC#5</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14GA</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14GA-88A-Boehm</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14GA-13B-Baer</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>88</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>Region 88</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS-88-Grakasian(HELP)</strong></td>\n"
+ "<td nowrap=\\\"nowrap\\\" style=\\\"width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS-13-Way</strong></td>\n"
+ "</tr>\n"
+ "</tbody>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}