#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td.+>(?:<.*>)*?(.+?)(?:<.*>)*?<\/td>"
Local $sString = "<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><bold>1/29/2017</bold></td>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>5070</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\">1/29/2017</td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>11:00 AM</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>88-14-Glendale SC#5</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS-88-Grakasian</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS-13-Way</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>88</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>Region 88</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>Region 88</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>Region 88</strong></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>6022</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>1/29/2017</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>12:30 PM</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>88-14-Glendale SC#5</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14GA</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14GA-88A-Boehm</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14GA-13B-Baer</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>88</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>Region 88</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS-88-Grakasian(HELP)</strong></td>" & @CRLF & _
"<td nowrap=\"nowrap\" style=\"width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\"><strong>U14BS-13-Way</strong></td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")