# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<td.+>(?:<.*>)*?(.+?)(?:<.*>)*?<\/td>"
test_str = ("<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><bold>1/29/2017</bold></td>\n\n\n\n\n"
"<tbody>\n"
"<tr>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>5070</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\">1/29/2017</td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>11:00 AM</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>88-14-Glendale SC#5</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS-88-Grakasian</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS-13-Way</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>88</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>Region 88</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>Region 88</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>Region 88</strong></td>\n"
"</tr>\n"
"<tr>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 47px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>6022</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>1/29/2017</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 60px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>12:30 PM</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 78px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>88-14-Glendale SC#5</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 45px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14GA</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 93px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14GA-88A-Boehm</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14GA-13B-Baer</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 42px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>88</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 96px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>Region 88</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 114px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS-88-Grakasian(HELP)</strong></td>\n"
"<td nowrap=\\\"nowrap\\\" style=\\\"width: 102px;height: 26px;mso-line-height-rule: exactly;-ms-text-size-adjust: 100%;-webkit-text-size-adjust: 100%;\\\"><strong>U14BS-13-Way</strong></td>\n"
"</tr>\n"
"</tbody>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.