re = /(?:lazy_)?gtxt\(([\"'])(?:(?!\1)[^\\]|\\.)*\1\)/m
str = 'gtxt(\'hi there "bob"\') how are you gtxt(\'i am fine\')
gtxt(\'hi there \\\'bob\\\'\') how are you gtxt("i am fine")
gtxt("hi there \\"bob")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end