import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:lazy_)?gtxt\\(([\\\"'])(?:(?!\\1)[^\\\\]|\\\\.)*\\1\\)";
final String string = "gtxt('hi there \"bob\"') how are you gtxt('i am fine')\n"
+ "gtxt('hi there \\'bob\\'') how are you gtxt(\"i am fine\")\n"
+ "gtxt(\"hi there \\\"bob\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}