#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:lazy_)?gtxt\(([\"'])(?:(?!\1)[^\\]|\\.)*\1\)"
Local $sString = "gtxt('hi there "bob"') how are you gtxt('i am fine')" & @CRLF & _
"gtxt('hi there \'bob\'') how are you gtxt("i am fine")" & @CRLF & _
"gtxt("hi there \"bob")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")