using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:lazy_)?gtxt\(([\""'])(?:(?!\1)[^\\]|\\.)*\1\)";
string input = @"gtxt('hi there ""bob""') how are you gtxt('i am fine')
gtxt('hi there \'bob\'') how are you gtxt(""i am fine"")
gtxt(""hi there \""bob"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}