$re = '/(?:lazy_)?gtxt\(([\"\'])(?:(?!\1)[^\\\\]|\\\\.)*\1\)/m';
$str = 'gtxt(\'hi there "bob"\') how are you gtxt(\'i am fine\')
gtxt(\'hi there \\\'bob\\\'\') how are you gtxt("i am fine")
gtxt("hi there \\"bob")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);