import Foundation
let pattern = ##"((?<!<[^>]*)> ((\d{1,}\.|-|\/\/|\%\%|\#) )?(\[[x ]\] )?)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
> - 测试
> - [ ] 测试
> - [x] 测试
> 1. 测试
> 2. [ ] 测试
> 2. [x] 测试
>
> - (✅)测试
> - [ ] (✅)测试
> - [x] (✅)测试
> 1. (✅)测试
> 2. [ ] (✅)测试
> 2. [x] (✅)测试
>
> 测试
> - 测试
> - [ ] 测试
> - [x] 测试
> <mark style="background: #ffcc33aa;">demo</mark> 测试
> // 测试
> %% 测试 %%
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)