import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!<[^>]*)> ((\\d{1,}\\.|-|\\/\\/|\\%\\%|\\#) )?(\\[[x ]\\] )?)";
final String string = "> - 测试\n"
+ "> - [ ] 测试\n"
+ "> - [x] 测试\n"
+ "> 1. 测试\n"
+ "> 2. [ ] 测试\n"
+ "> 2. [x] 测试\n"
+ "> \n"
+ "> - (✅)测试\n"
+ "> - [ ] (✅)测试\n"
+ "> - [x] (✅)测试\n"
+ "> 1. (✅)测试\n"
+ "> 2. [ ] (✅)测试\n"
+ "> 2. [x] (✅)测试\n"
+ "> \n"
+ "> 测试\n"
+ "> - 测试\n"
+ "> - [ ] 测试\n"
+ "> - [x] 测试\n"
+ "> <mark style=\"background: #ffcc33aa;\">demo</mark> 测试\n\n"
+ "> // 测试\n"
+ "> %% 测试 %%\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}